ERROR: The request requires HTTPS

Last Month
DaisukeO
Work Portal - Others

Summary

When trying to get a bearer token to start invoking OData services, you get a "The request requires HTTPS" error message:



 

Applies to

Bizagi 11.1 version and above.

Symptoms

You can't get started using OData services, and you have already tried targeting the service's URL by using both HTTP and HTTPS.

You have already registered an OAuth2 app at the Bizagi Work portal for this use:

 

Cause

The redirect URI attempted by the OData service is not set to use HTTPS.

Solution

Ensure that the OAuth2 app you have registered at the Bizagi Work portal, uses a HTTPS-based redirect URI:

 

Once you perform this change, the OData service will respond correctly. 

 


Rate this Article:

Details

Last Modified:Last Month
Last Modified By: DaisukeO
Type: ERROR
Level: Beginner
Article not rated yet.
Article has been viewed 190 times.

Options