The user does not exist in Bizagi



Summary

End users may detect that some scheduled activities are not executed. Server Administrators will find error messages in the Event Viewer stating: "The user does not exist in BizAgi".

Applies to

Bizagi Studio .NET 10.x

Symptoms

The scheduled activities like Timers, Alarms and, Re-trials of Asynchronous Activities are not executed and the server's Event Viewer where Bizagi Scheduler Service is installed shows an error with the following description:

Source:
Authentication Manager
Message:
The user does not exist in BizAgi
Stack Trace:
   at BizAgi.Authentication.CAuthenticationManager.loadUser(String sDomain, String sUsername, String sClientIP, Boolean validateEnabled)
   at BizAgi.Authentication.CAuthenticationManager.loadUser(String sDomain, String sUsername)

Cause

This problem is generally presented when there are inconsistencies in the Admon user account, like the following:

  • The account has been renamed
  • The account has been disabled
  • The account’s domain has been changed.

Solution

Reverse the changes made over the user Admon, and make sure that this account is enabled and belongs to ‘Domain’ domain.
Avoid performing any modification over Admon account. This account is internally used by Bizagi in order to perform some activities like those executed by Bizagi Scheduler Service.