Summary
When
configuring Bizagi Work portal to run on a JEE application server, such
as WebSphere, all steps are successful but the Work portal will show an
incomplete/blank login screen:
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Applies to
Bizagi
JEE All versions
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Symptoms
Specifically,
the Work portal cannot be used given that it does not load up
completely.
The browser console does not illustrate on a specific cause, however
the JEE application server log may include details about UnsupportedClassVersionError.

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Cause
Whenever
an unsupported version error shows up, double-check the Java version
used to generate your .ear
application.
A bad major version stack message may indicate that you are using a
higher Java version than that one supported (e.g., using JDK 7 or 8 for
a 10.x release).
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Solution
Ensure you repeat steps to generate the .ear application by using the JEEConsoleManager.
This time, explicitly set the use of any Java version as supported by
Bizagi version. |