Code error: 12903 Could not find the BizAgi.EntityManager.Entities assembly

7 Years Ago
Administrator
SCHEDULER AND UNDERLYING SERVICES
ERROR

Summary

The Temporary ASP.NET files generate an error message when creating a new case in the Work Portal.

Applies to

Bizagi .NET 10.x

Symptoms

The following error is shown in the Work Portal as soon as a new case is created:

Functional Information
Execution List
Error
Code error: 11859 Error on ProcessForm
Code error: 12903 Could not find the BizAgi.EntityManager.Entities
assembly
Please try again later. If the error persists contact the system
administrator.
 
Technical error
Source
System.Web
BizAgi.Render.Old
BizAgi.BL

Cause

The .NET Framework saves in cache some objects and are not renewed automatically. Thus, when Bizagi tries to present the Work Portal there is an internal conflict and the message is presented.

Solution

The user needs to force the recreation of recently updated objects:

1. In the application server, stop the IIS (for example using the iisreset /stop command in the command prompt window).

2. Delete the temporary files of .NET Framework 2.0 deleting the contents of the folder
C:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\ (for a 32 bits project)
or
C:\Windows\Microsoft.NET\Framework64\v4.0.xxxxx\Temporary ASP.NET Files\ (for a 64 bits project).

3. Delete the content of the EntityManager folder of the project, usually found in
C:\BizAgi\Projects\[PROJECT_NAME]\EntityManager
and
C:\BizAgi\Projects\[PROJECT_NAME]\Temporary\EntityManager

4. Restart the IIS (using the iisreset /start command in the command prompt window).

Rate this Article:

Details

Last Modified:7 Years Ago
Last Modified By: JorgeR
Type: ERROR
Level: Beginner
Rated 3 stars based on 7 votes.
Article has been viewed 65.8K times.

Options