Videos
in .mp4 and .mov formats cannot be reproduced in iPads
Summary
The
error occurs when a video is captured and uploaded in a FileUpload
control. When trying to reproduce this video in an iPad, it is not
possible to
view the footage and a Play button in a cancelled state is shown
instead:

Applies
To
Automation
Server (on-premises only)
Symptoms
The
mobile
application server is unable to recognize .mp4 or .mov video formats.
Cause
There
is a problem in the server’s infrastructure that hinders
communication between the mobile application and the BPM server when
trying to
reproduce videos in .mp4 or .mov formats correctly. As it is not
possible to do
a fix in the application or the BPM server to solve the issue, the
server’s infrastructure
needs to be modified via the Registry Editor.
Solution
To
solve the
error, follow these steps:
1.
Open
the Registry Editor.

2.
Expand
the HKEY_CLASSES_ROOT node and look for the
.mov and .mp4 records.

3.
If
such records exist, delete them. To do this, right click the record name and the select the Delete option.


4.
Once
you have done this, import the mov.reg and
mp4.reg files (both files can be downloaded here).


5.
Windows
imports the data from the files and displays
a confirmation message.

Recommendations
-
It
is advisable to restart the server to ensure that the modified
settings were applied.
- It
is recommended to upload a new video in the form before attempting
its reproduction, as the video’s metadata might be corrupted.